Issues Creating / Joining / Starting Multiplayer Games, AI Skirmish or 1v1 Ranked?

Discussion in 'Support!' started by mikeyh, June 17, 2015.

  1. mikeyh

    mikeyh Post Master General

    Messages:
    1,745
    Likes Received:
    1,498
    If you have issues with creating / joining / starting multiplayer games in the server browser or 1v1 ranked matches then check the following...

    Login Accepted
    1. Try with mods disabled
    2. Check your name does not have special characters outside of UTF-8.
      Your logs will show lots of: Error decoding message from server: malformed UTF-16 sequence

      https://wiki.palobby.com/wiki/Special_Characters_in_Display_Name

    Requesting Permission


    This can happen in two scenarios:
    • when there is an issue resolving the game lobbyId to a server instance
      eg instance terminated while you tried to join
    • when there is contention for remaining slots typically the last slot
    Either wait for the timeout or restart PA.

    Incompatible Windows Software

    Check this list:

    Reporting Issues

    Sim Performance / Time Dilation, RAM Usage, Planets and CSG

    A high spec dedicated server will always out perform an Uber public shared server:
    Games with large systems containing many big planets with lots of CSG and many players that horde thousands of units are not going to perform well on any server:

    Client Stalls or Units Jump During Game

    This is normally a network issue.

    https://wiki.palobby.com/wiki/Unit_Freezes_/_Unit_Jumps_/_Stuttering

    mtr is the simplest way to see packet loss and network issues:
    You have a couple of options on windows:
    You can test your network connection to a server with the following:
    • create a a private game
    • check your most recent logs for the last Connect to [host : port] worked eg 174.37.76.35:9003
    • run mtr or another tool against that ip address eg mtr 174.37.76.35
    The game has to be active to make sure the server instance is not reclaimed.

    You'll get something like this from mtr on linux: (I've removed my local network data)

    Code:
    Host                                           Loss%   Snt   Last   Avg  Best  Wrst StDev
    <snip>
    3. ae-0-942.cr1.mdr.vygr.net                    0.0%   253    5.1   7.9   4.3  91.6  10.2
    4. 203.97.9.97                                  0.0%   253    5.1   7.4   4.4  72.7   8.0
    5. unknown.telstraglobal.net                    0.0%   253    8.3   8.8   5.7  48.5   4.4
    6. i-0-6-4-1.tlot-core01.bx.telstraglobal.net   0.0%   253  132.4 132.7 130.3 137.5   1.3
    7. i-0-4-0-8.eqnx-core01.bi.telstraglobal.net   0.0%   253  162.7 163.8 160.9 183.4   2.3
    8. i-0-5-0-0.eqnx03.bi.telstraglobal.net        0.0%   253  162.0 163.4 161.3 257.0   8.0
    9. te1-7.bbr01.eq01.sjc01.networklayer.com      0.0%   253  161.9 162.6 161.1 186.0   3.3
    10. ae7.bbr02.eq01.sjc02.networklayer.com        0.0%   253  162.5 162.7 161.2 248.7   5.9
    11. ae0.bbr02.cs01.lax01.networklayer.com        0.0%   253  169.6 170.1 168.7 213.6   3.8
    12. ae7.bbr01.cs01.lax01.networklayer.com        0.0%   252  169.1 170.3 168.4 332.7  11.4
    13. ae19.bbr01.eq01.dal03.networklayer.com       0.0%   252  196.8 196.9 195.8 221.2   1.8
    14. ae0.dar01.sr01.dal01.networklayer.com        0.0%   252  200.3 200.5 199.5 221.3   2.2
    15. po1.fcr04.sr05.dal01.networklayer.com        0.0%   252  199.4 201.0 198.8 248.8   5.9
    16. 174.37.76.35-static.reverse.softlayer.com    0.0%   252  196.5 196.5 196.2 198.3   0.2
    
    Last edited: January 31, 2017
    Clopse, tunsel11, elodea and 3 others like this.
  2. mikeyh

    mikeyh Post Master General

    Messages:
    1,745
    Likes Received:
    1,498
    Changed to include both creating and joining multiplayer games.
    tunsel11 likes this.
  3. mikeyh

    mikeyh Post Master General

    Messages:
    1,745
    Likes Received:
    1,498
    Added replay loading issue.
  4. mikeyh

    mikeyh Post Master General

    Messages:
    1,745
    Likes Received:
    1,498
    Added 1v1 ranked matches.
  5. mikeyh

    mikeyh Post Master General

    Messages:
    1,745
    Likes Received:
    1,498
    I'll add automatic optimising of the user tag map next week.
    proeleert likes this.
  6. killerkiwijuice

    killerkiwijuice Post Master General

    Messages:
    3,792
    Likes Received:
    3,515
    This should be stickied :)
    proeleert likes this.
  7. redpiner

    redpiner New Member

    Messages:
    16
    Likes Received:
    6
    Oddly enough, my very first 1v1 ranked game worked just fine despite having PAMM mods active. All my problems seemed to start after a failure to connect to a 1v1 ranked, forcing me to abandon game for a 20 minutes timeout penalty (despite multiple attempts to reconnect to my game), followed by being unable to join any multiplayer games (ranked or custom) due to the "Requesting Permission" screen. The "Requesting Permission" screen sometimes times out after a minute, but sometimes it stays there past 5 minutes forcing a PA restart.

    I tried uninstalling PAMM and PA classic to no avail, I'll try reinstalling PA Titans next.

    EDIT: Reinstalled PA:T. Apparently I'm still "Assigned to a game" which I can't "reconnect" to and don't want to "abandon" because of the 20 minute penalty. Meanwhile, I can't connect to Galactic War, much less replays, due to the "Requesting Permission" -> "Failed to Connect" screens. At least the "Requesting Permission" screen only lasts a few minutes now.
    Last edited: August 23, 2015
  8. cola_colin

    cola_colin Planetary Moderator

    Messages:
    12,114
    Likes Received:
    16,239
    I think atm there is a general server problem. Probably just need to wait a bit for it to resolve.
  9. jerle78

    jerle78 Member

    Messages:
    34
    Likes Received:
    11
    I just upgraded to Titans and it seems like the "Requesting permission" bug is even more prevalent than it was before. This may be due to increased activity with the game. More people have come back since the expansion was released.
  10. redpiner

    redpiner New Member

    Messages:
    16
    Likes Received:
    6
    Hmm, could be. Still, I find it odd that I get the "You are already assigned to a game. Reconnect/Abandon?" screen even though I've been logged out of PA for over 5 hours.

    The server issues are a real shame, as I really love the expansion.
  11. redpiner

    redpiner New Member

    Messages:
    16
    Likes Received:
    6
    I finally figured out the cause of most of my problems. I tried to uninstall PAMM with the "uninstall/remove programs" tool, but that only got rid of the PAMM shortcut. Despite having "uninstalled" PAMM the mods were still active, and breaking the game on me. I had to go into %appdata% and delete PAMM manually. This solved my problems.
  12. cola_colin

    cola_colin Planetary Moderator

    Messages:
    12,114
    Likes Received:
    16,239
    To disable all mods just open PAMM and select disable all for UI and server mods.
  13. mikeyh

    mikeyh Post Master General

    Messages:
    1,745
    Likes Received:
    1,498
  14. entz

    entz New Member

    Messages:
    9
    Likes Received:
    6
    I just got "Loading Replay" forever when joining 1v1 Ranked
  15. mikeyh

    mikeyh Post Master General

    Messages:
    1,745
    Likes Received:
    1,498
  16. mikeyh

    mikeyh Post Master General

    Messages:
    1,745
    Likes Received:
    1,498
    Added login accepted with broken mods and UTF-16 glyphs in display name.
  17. checkbox2

    checkbox2 New Member

    Messages:
    3
    Likes Received:
    0
    The issue also appears when no mods are used, or special characters in name...
    2 me this smells more of a network (timeout-pending) issue 2 me..

    The game launches, i even 1 time heard the sound when u enter the 'galaxy', and then , where ussually my processor goes in overdrive... now its waiting and idling ...
  18. imperatorurist

    imperatorurist Member

    Messages:
    72
    Likes Received:
    62
    Still frezzing on the loading screens.
  19. warrenkc

    warrenkc Active Member

    Messages:
    542
    Likes Received:
    191
    OMG they still have the problem that needs a mod to fix it? Optimize user map? Wow. Just wow
  20. mikeyh

    mikeyh Post Master General

    Messages:
    1,745
    Likes Received:
    1,498
    Hotfix 89528 has been released to fix 1v1 ranked and the loading replay issue is hopefully resolved now.
    mkrater likes this.

Share This Page